[webkit-dev] Moving methods from layoutTestController to window.internals (was "We should rename layoutTestController to testController")
jesus at webkit.org
Thu May 31 14:15:17 PDT 2012
2012/5/31 Ojan Vafai <ojan at chromium.org>:
> Darin, sorry for derailing this thread. I suppose I should have changed the
> subject. :)
> On Thu, May 31, 2012 at 1:51 PM, Jesus Sanchez-Palencia <jesus at webkit.org>
>> We were following the
>> "if-it-depends-only-on-WebCore-code-it-should-be-moved" idea quite
>> strictly, but now it seems we are facing a trade-off about internals x
>> private WebKit APIs/SPIs from a few ports being tested. In other
>> words, a few methods from layoutTestController are also testing code
>> (private?) from WebKit and moving them to internals can leave these
>> untested... For Qt I'm removing private methods that were only used by
>> DRT or WTR, but I can't make this decision for other ports.
> If any of these involve the Chromium port, I'm sure we'd be happy to
> accommodate whatever is needed to move the API to internals. Feel free to CC
> me on bugs where that's the case.
Good to know, thanks!
It would be nice if people from other ports could also raise their
hands as well so we don't bother the wrong ones.
By the way, following the meta bug I could see that there are a few
patches needing some care from reviewers, guys!
>> Anyway, if you know something that can be moved for sure, just open a
>> bug blocking b87284 and I'm quite sure there will be people happy to
>> work on it.
>> > Work on exposing things like eventSender through an NPAPI plugin. That
>> > way
>> > it can be shared across browser vendors and could be used by the W3C
>> > test
>> > harness as well. This would be for APIs that we want for testing but
>> > don't
>> > make sense to expose to the web.
>> > Ojan
>> > On Thu, May 31, 2012 at 11:56 AM, Darin Adler <darin at apple.com> wrote:
>> >> I am thinking we should rename layoutTestController to testController.
>> >> Or
>> >> if you don’t like that name, maybe testHarness or some even better
>> >> name.
>> >> The old name is too long and the word “layout” is so strange.
>> >> We could expose the object under the new name and the old one, and then
>> >> over time convert all the tests to the new name, then get rid of the
>> >> old
>> >> one.
>> >> What do you all think?
>> >> -- Darin
>> >> _______________________________________________
>> >> webkit-dev mailing list
>> >> webkit-dev at lists.webkit.org
>> >> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
>> > _______________________________________________
>> > webkit-dev mailing list
>> > webkit-dev at lists.webkit.org
>> > http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
More information about the webkit-dev