[webkit-dev] TestExpectations syntax changes, last call (for a while, at least) ...
rniwa at webkit.org
Thu Jun 14 13:47:00 PDT 2012
On Thu, Jun 14, 2012 at 1:44 PM, Peter Kasting <pkasting at chromium.org>wrote:
> On Thu, Jun 14, 2012 at 1:39 PM, Elliot Poger <epoger at chromium.org> wrote:
>> Can someone please remind me why IMAGE+TEXT even exists?
>> Wouldn't it be simpler to just mark a test as follows?
>> - IMAGE : allow image failure; go red if there is a text failure
>> - TEXT: allow text failure; go red if there is an image failure
>> - IMAGE TEXT: allow text and/or image failure
>> The distinction is that IMAGE TEXT will allow image, text, or both to
> fail, thus making transitions among the three generate no events.
> IMAGE+TEXT says specifically that we expect both to fail and that if one
> starts passing, someone should do something. (For example, maybe someone
> checks in a partial rebaseline where they miss the image expectations.)
Not to bike-shed on anything, but I think we should rename Text and Image
to TextOnly and ImageOnly. Every single person I know, including myself,
had never got the distinction between IMAGE TEXT and IMAGE+TEXT without
someone explaining it to him/her .
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev