[webkit-dev] TestExpectations syntax changes, last call (for a while, at least) ...
dpranke at chromium.org
Wed Jun 13 16:29:56 PDT 2012
On Wed, Jun 13, 2012 at 3:58 PM, Darin Adler <darin at apple.com> wrote:
> On Jun 13, 2012, at 3:53 PM, Dirk Pranke <dpranke at chromium.org> wrote:
>> * we use "\" (backslash) as a delimiter instead of ":" and "="
> Seems worse to me. When I see a backslash I assume it’s a line continuation character or a C escape sequence.
> On the other hand, neither the ":" nor the "=" meant anything to me either, and I suggested dropping the delimiter entirely, so I’m not sure my feedback will get listened to!
That's a bit harsh. "listened to" does not necessarily mean "will do
what you ask" :). Plenty of other people have said that they liked
delimiters, so I think you just got outvoted.
Are there other delimiters you might prefer to ':' and '=' ? Others
suggestions have included bracketing the test name , and or uniformly
using one of : , = - ; , or as Benjamin or Ryoskue have suggested,
bracketing the keywords ...
For the record, I didn't like bracketing the test name since brackets
make it look optional. I could be open to bracketing the modifiers and
keywords, since the modifiers are optional, and it would seem
reasonable to make the absence of keywords equivalent to SKIP ...
>> * As of now the keywords remain all UPPERCASE. I'm happy to change them to all lowercase or mixed case if there's a consensus that such a change is desired.
> I DON'T LIKE READING THINGS IN ALL UPPERCASE AND WOULD VERY MUCH LIKE THAT TO CHANGE.
Would you prefer lowercase, lowercase_with_underscores, Initialcaps,
MixedCase ... ?
On Wed, Jun 13, 2012 at 4:12 PM, Benjamin Poulain <benjamin at webkit.org> wrote:
> On Wed, Jun 13, 2012 at 3:53 PM, Dirk Pranke <dpranke at chromium.org> wrote:
>> webkit.org/12345 WIN MAC DEBUG \
>> animations/stop-animation-on-suspend.html \ CRASH TEXT PASS
> My bikeshedding:
> -In my opinion, the backslash is not any better than the old
> delimiter. It looks like we are escaping something.
> I liked better the proposal to have platform and results grouped
> instead of the delimiter.
> e.g: webkit.org/12345 (WIN MAC DEBUG)
> animations/stop-animation-on-suspend.html (CRASH TEXT PASS)
> -I prefer lowercase keywords, possibly with the first character
> uppercase (Crash, Text, Pass, Fail, Win, Mac, Debug). Do we use all
> uppercase keywords somewhere else in the project?
C++ macros are the only place I know of.
More information about the webkit-dev