[webkit-dev] TestExpectations syntax changes, last call (for a while, at least) ...
rniwa at webkit.org
Wed Jun 13 16:26:53 PDT 2012
On Wed, Jun 13, 2012 at 4:12 PM, Benjamin Poulain <benjamin at webkit.org>wrote:
> On Wed, Jun 13, 2012 at 3:53 PM, Dirk Pranke <dpranke at chromium.org> wrote:
> > webkit.org/12345 WIN MAC DEBUG \
> > animations/stop-animation-on-suspend.html \ CRASH TEXT PASS
> My bikeshedding:
> -In my opinion, the backslash is not any better than the old
> delimiter. It looks like we are escaping something.
> I liked better the proposal to have platform and results grouped
> instead of the delimiter.
> e.g: webkit.org/12345 (WIN MAC DEBUG)
> animations/stop-animation-on-suspend.html (CRASH TEXT PASS)
> -I prefer lowercase keywords, possibly with the first character
> uppercase (Crash, Text, Pass, Fail, Win, Mac, Debug). Do we use all
> uppercase keywords somewhere else in the project?
So something like
webkit.org/12345 [Win Mac Debug] animations/stop-animation-on-suspend.html
[Crash Text Pass]
? I like that!
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev