[webkit-dev] Rename of selfOnlyRef to guardRef - ok if I change it back? (was Re: DOM tree traversal on detached nodes)

Maciej Stachowiak mjs at apple.com
Mon Jun 11 18:14:19 PDT 2012

On Jun 11, 2012, at 6:06 PM, Maciej Stachowiak <mjs at apple.com> wrote:

>  not a self-only reference (at some point renamed to guardRef). 

BTW I was able to find where it was renamed but not a good explanation of why. I think selfOnlyRef() was a much clearer name.

The history seems to be that it was renamed when moved from Document to TreeScope (without explanation in the bug or ChangeLog, and apparently retaining it's self-only referencing behavior per comments):


Then later it was moved back to Document but retaining the rename:


Would anyone object if I renamed it back? Alternately, could the reason for the new name be documented somewhere?


More information about the webkit-dev mailing list