[webkit-dev] Rename FAIL to DIFF Was (Re: PSA: FAIL test expectation does not encompass MISSING, CRASH, or TIMEOUT)
rniwa at webkit.org
Thu Jun 7 13:03:24 PDT 2012
On Thu, Jun 7, 2012 at 12:59 PM, Dirk Pranke <dpranke at chromium.org> wrote:
> FAIL was supposed to have been removed long ago in favor of
> TEXT/IMAGE/IMAGE+TEXT as necessary as Peter suggests, but I never got
> around to it :) I agree with his reasoning, and have not been
> convinced that not having to be specific about what is failing is a
> good thing.
Let's do that then.
I also agree that we shouldn't TEXT/IMAGE/IMAGE+TEXT in the file at
> all for extended periods of time since you can just check in updated
I'd argue that we should never add test expectations pre-emptively just to
keep bots green. It appears to do more harm than good.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev