[webkit-dev] Renaming DumpRenderTree to WebKitTestRunner or merging those two
abarth at webkit.org
Sat Jun 2 20:03:00 PDT 2012
We might also want to define the layoutTestController object with IDL
so we don't have to hand-write bindings every time we change it.
Using IDL for window.internals seems to have worked out well. It
would be nice to replicate that success with layoutTestController.
On Sat, Jun 2, 2012 at 6:55 PM, Ryosuke Niwa <rniwa at webkit.org> wrote:
> One thing that has annoyed me ever since I started working on WebKit is that
> our test runner is called DumpRenderTree. We fixed this problem in WebKit2
> by renaming it to WebKitTestRunner but we've still got DumpRenderTree in
> WebKit1 land.
> Can we either rename DumpRenderTree to WebKitTestRunner or merge those two
> programs into one?
> Ryosuke Niwa
> Software Engineer
> Google Inc.
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
More information about the webkit-dev