[webkit-dev] Should we move methods from layoutTestController/etc... to internals?

Dimitri Glazkov dglazkov at chromium.org
Tue Feb 21 15:43:13 PST 2012

On Tue, Feb 21, 2012 at 3:39 PM, Ryosuke Niwa <rniwa at webkit.org> wrote:
> On Tue, Feb 21, 2012 at 3:14 PM, Maciej Stachowiak <mjs at apple.com> wrote:
>> On Feb 21, 2012, at 1:21 PM, Ryosuke Niwa wrote:
>> > I'd prefer getting rid of the entire interface when possible. We're
>> > obviously removing layoutTestController, textInputController, etc... at the
>> > moment though.
>> I think it's helpful to organize the methods by functional area instead of
>> dumping them all onto one giant interface. layoutTestController for example
>> has far too many methods, in my opinion. We would not design a public API
>> where every method is on one global interface, and our testing API should
>> not look that way either. I would like to see our test API split up more,
>> rather than combined into a single interface.
> Yeah, that'll be nice. Maybe morrita and dglazkov have an idea on how to do
> this nicely?

I kind of like this plan: https://bugs.webkit.org/show_bug.cgi?id=76423


>> I'm also confused about your examples of interfaces you are "obviously"
>> removing. Did you mean "obviously not removing"?
> Sorry. Yes, it should read "obviously NOT removing".
> - Ryosuke

More information about the webkit-dev mailing list