[webkit-dev] starting implementation of postMessage tranferables

Ian Hickson ian at hixie.ch
Thu Sep 22 19:46:53 PDT 2011


On Thu, 22 Sep 2011, David Levin wrote:
>
> *Summary*: Implementing postMessage with transferable support as
> webkitPostMessage.
> 
> *Details*:
> *Spec*:
> http://www.whatwg.org/specs/web-apps/current-work/multipage/comms.html#posting-messages
> 
> This describes window.postMessage and the same is true for Message Ports and
> Worker Context. It doesn't mention Array Buffers but that will be mentioned
> soon and is in the spec that talks about Array Buffers.
> 
> Tracking bug: https://bugs.webkit.org/show_bug.cgi?id=64629
> 
> *Plan*:
> 1. Add webkitPostMessage to all of these places to isolate us from possible
> spec changes. It will have the same functionality as postMessage.
> 2. Add the ability to transfer Message Ports.
> 3. Add the ability to transfer Array Buffers.

After step 2, webkitPostMessage can be renamed to postMessage quite 
safely. The spec isn't going to change in a way that breaks you.

-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'


More information about the webkit-dev mailing list