[webkit-dev] Change to style guideline: should use type& instead of type* for out arguments
eric at webkit.org
Tue Oct 4 18:14:33 PDT 2011
Interesting. I thought historical policy was universally against the
word "get" in function names. I guess you're suggesting that "get"
should only be applied to function names which have an out-argument?
On Tue, Oct 4, 2011 at 6:00 PM, Darin Adler <darin at apple.com> wrote:
> On Oct 4, 2011, at 2:06 PM, Ryosuke Niwa wrote:
>> It came to my attention that some people are using raw pointers to pass out-arguments (e.g. bug 69366). In my understanding, we use pass by reference for out arguments when they have to be modified in callees.
>> If there's no objection, I'm going to file a bug & upload a patch to state this explicitly in the style guideline.
> If it’s not already in there, I think you might also want to mention the related rule that encourages the use of the word “get” at the starts of the names of these functions with out arguments.
> -- Darin
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
More information about the webkit-dev