[webkit-dev] Possible rule of thumb for FrameLoader vs. DocumentLoader code
darin at apple.com
Fri Jun 24 16:57:21 PDT 2011
I have an idea for a rule of thumb for what code should be in FrameLoader and what should go in DocumentLoader.
I’d suggest that we leave code in frame loader that relates to switching from one document to the next. Starting a navigation to a new location, creating a document loader for the new location, that sort of thing.
And we move code from frame loader to document loader that relates to loading once a document loader exists. Pretty much anything you do in the context of a document that’s already loaded would be in document loader. My brief perusal of the current code in frame loader gives me the impression that this would be more than 50% of the code still in there.
My hope is that we’d move both functions and data based on this rule of thumb. It may be tricky to do this without breaking anything, some things may currently work for strange or unintentional reasons and rely on state that outlasts the document loader.
Thoughts on this?
More information about the webkit-dev