[webkit-dev] What is the minimal version of Python for webkit-patch?

Eric Seidel eric at webkit.org
Tue Feb 22 14:04:34 PST 2011

That said, I'm *very* excited to see patches supporting 3.0. :)  Just
please don't break 2.5 support.

On Tue, Feb 22, 2011 at 2:04 PM, Eric Seidel <eric at webkit.org> wrote:
> We expect all python in webkit to work in Python 2.5.
> We arrived at that version by looking at the lowest version shipping
> on the common platforms used for webkit development.  Mac OS X Leopard
> was the platform with the lowest shipping python version (2.5).
> If/when Apple stops actively developing WebKIt for Leopard (which I
> don't expect to be until after Lion ships) we as a project will
> certainly move to 2.6+ (as that's what Snow Leopard supports).
> It's possible we'll move to requiring a newer python version for
> WebKit before that time, but that's unlikely given that currently it's
> annoying to have to upgrade everyone's development machines.
> -eric
> On Tue, Feb 22, 2011 at 1:20 PM, Benjamin <ikipou at gmail.com> wrote:
>> Hello,
>> I would like to update webkit-patch to support Python 3 because that is what
>> I use by default.
>> I think that would not be too much problem to support Python >= 2.6. If we
>> have to support as low as Python 2.4, that could be a problem because of
>> some new syntax elements introduced in 2.6.
>> Should I wait before patching for Python 3? Anyone needs webkit-patch for
>> Python < 2.6?
>> cheers,
>> Benjamin
>> _______________________________________________
>> webkit-dev mailing list
>> webkit-dev at lists.webkit.org
>> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

More information about the webkit-dev mailing list