[webkit-dev] Moving code from Element to NamedNodeMap -- I think that is the wrong direction
adamk at chromium.org
Thu Dec 22 09:45:55 PST 2011
On Wed, Dec 21, 2011 at 11:32 PM, Darin Adler <darin at apple.com> wrote:
> On Dec 21, 2011, at 11:26 PM, Ryosuke Niwa wrote:
> > the immediate problem we have today is that code that updates and
> notifies attributes are scattered all over the place, and making
> refactoring harder
> Understood. I want to make sure that as we do improvements, we move in the
> right direction. Moving more code to NameNodeMap is unfortunate; I would
> have moved the code in the other direction. Now that we have discussed
> this, I trust that what you and Adam are doing will keep this direction in
Definitely will. As Ryosuke pointed out, the latest patch (
webkit.org/b/75054) will consolidate most of the logic in a few methods
which could be easily moved from NamedNodeMap into Element if need be. In
putting together this set of patches, it's been very clear that there's not
a clean separation between Element and NamedNodeMap anyway, so it's good to
have the suggestion that the code should all live in Element (since
splitting it is just confusing).
Probably won't get into any more of this before holiday, but I'll give the
bugs you filed a look and plan to do some more cleanup in the new year.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev