[webkit-dev] Moving code from Element to NamedNodeMap -- I think that is the wrong direction

Darin Adler darin at apple.com
Wed Dec 21 23:32:00 PST 2011

On Dec 21, 2011, at 11:26 PM, Ryosuke Niwa wrote:

> the immediate problem we have today is that code that updates and notifies attributes are scattered all over the place, and making refactoring harder

Understood. I want to make sure that as we do improvements, we move in the right direction. Moving more code to NameNodeMap is unfortunate; I would have moved the code in the other direction. Now that we have discussed this, I trust that what you and Adam are doing will keep this direction in mind.

> Could you file bugs for these goals so that Adam and I can tackle those after the break?

Sure. Not tonight, but as soon as I get a chance.

-- Darin

PS: I still haven’t even responded to the discussion about ASSERT_NO_EXCEPTION—I do have some further thoughts on that—so I am feeling a bit behind!

More information about the webkit-dev mailing list