[webkit-dev] Coding style change - Indentation of forward declarations in headers

David Hyatt hyatt at apple.com
Mon Nov 1 10:00:19 PDT 2010

Yeah I agree with Peter.  I think blank lines after { and before } would improve the readability of the 2nd example even without indentation.

namespace WebCore {

class AuthenticationChallenge;
class CachedFrame;
class HistoryItem;
class ProtectionSpace;
class ResourceLoader;
class ResourceRequest;


This doesn't seem worth making a special case for to me.

(hyatt at apple.com)

On Nov 1, 2010, at 11:49 AM, Peter Kasting wrote:

> On Mon, Nov 1, 2010 at 9:40 AM, Brady Eidson <beidson at apple.com> wrote:
> I think this pattern increases readability of forward declarations in headers and we should change the style guidelines to specify its continued use.
> Thoughts?
> I don't find either one significantly better than the other, personally.
> PK 
> _______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20101101/74258beb/attachment.html>

More information about the webkit-dev mailing list