[webkit-dev] Python on the Tiger build bot

Eric Seidel eric at webkit.org
Sun May 9 16:50:58 PDT 2010

I am not certain as to which "agreement" you refer.  However, I can
understand that historically we viewed the python tools as less
"essential" than they appear to have become.

Just as we moved from CVS to SVN and at that time required all Tiger
machines to install an SVN package, so too today are an increasingly
large number of our scripts moving from depending on perl 5 to Python

I would appreciate assistance from the bot maintainer to update the
one Tiger machine, as it is the only machine which uses such an old
copy of Python.  All other operating systems/machines already use much
newer versions of Python.  The WebKit project requires Leopard's 2.5
python as a minimum installed version.

I will post a patch to update the tools.html page to note the
requirement shortly.


On Thu, May 6, 2010 at 9:54 PM, Alexey Proskuryakov <ap at webkit.org> wrote:
> I thought the agreement was that "essential" tools shouldn't add more requirements on the installed tools. Is it not the case?
> - WBR, Alexey Proskuryakov
> 06.05.2010, в 21:30, Eric Seidel написал(а):
>> WebKitTools/Scripts/webkitpy python requires 2.5+.
>> We'd like to be able to use python 2.5 on the Tiger build bot (for
>> websocket tests among other things).
>> Would someone be able to install a newer Tiger on that machine?
>> Here is python 2.6.5 for the mac:
>> http://www.python.org/ftp/python/2.6.5/python-2.6.5-macosx10.3-2010-03-24.dmg
>> Thanks!
>> -eric
>> _______________________________________________
>> webkit-dev mailing list
>> webkit-dev at lists.webkit.org
>> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

More information about the webkit-dev mailing list