[webkit-dev] minimum python version to support

Adam Barth abarth at webkit.org
Fri Mar 19 09:19:28 PDT 2010

My understanding is that some of the libraries we use, like Mechanize,
don't work in Python 2.4.  My complaint in Bug 36063 is that we're
re-implementing Mechanize poorly.  I'd rather we just upgraded the
machines that need to run-webkit-tests to a more modern version of


On Fri, Mar 19, 2010 at 7:41 AM, Chris Jerdonek <cjerdonek at webkit.org> wrote:
> No one responded back with a summary of the Python 2.4 discussion, so
> I'll attempt a summary of my own after reading--
> https://bugs.webkit.org/show_bug.cgi?id=35584
> (If you recall, we are trying to decide what Python code we write
> needs to work with Python 2.4.)
> The Chromium project still uses Python 2.4 in a significant way.  Some
> Chromium bots run new-run-webkit-tests using 2.4, and a number of
> developers use 2.4 in their development environments.  Generally
> speaking, people support upgrading, but no one is spearheading an
> upgrade and there is no ETA.
> For the time being, because of the bots, it seems like
> new-run-webkit-tests definitely needs to keep working with 2.4.  But
> for the tools used more in the development environment (webkit-patch,
> etc), it seems like people would be willing to find a way to make
> things work with 2.5+.
> It would be pretty easy to get all of our Python code working with 2.4
> (we had a patch for this a couple weeks ago), but going back wouldn't
> let us use some of the nicer constructs.  And we would have to contend
> with at least one bug in 2.4.
> (End of summary.)
> Plainly, the options seem to be--
> (1) All Python 2.5+
> (2) All Python 2.4
> (3) Some combination of (1) and (2) (e.g. new-run-webkit-tests 2.4,
> everything else 2.5)
> However, (1) does not seem to be an option.  Personally, I'm starting
> to lean more toward to (2).  One reason is that we are already
> starting to see a case of re-implementing in Python 2.4 (for
> new-run-webkit-tests) code that was already written in 2.5:
> https://bugs.webkit.org/show_bug.cgi?id=36063#c4
> I also think it would be helpful if we did not need to have this
> discussion for each new script we decide to write in Python.  I would
> be willing to update the patch from a couple weeks ago that adjusts
> things for 2.4.
> --Chris
> On Sun, Mar 7, 2010 at 4:18 PM, Chris Jerdonek <cjerdonek at webkit.org> wrote:
>> On Fri, Mar 5, 2010 at 6:43 PM, David Kilzer <ddkilzer at webkit.org> wrote:
>>> On Thu, March 4, 2010 at 5:35:08 PM, William Siegrist wrote:
>>>> Since I have a Tiger machine handy, I tested this and was able to build python
>>>> 2.5.5 from MacPorts on a PowerPC. It takes a while, but it worked. I did not try
>>>> python 2.6.
>>> I've installed python 2.6.4 using MacPorts on my PowerBook G4 running Tiger 10.4.11, and it's worked find with webkit-patch the one or two times I tried it.
>> That sounds great.  Thanks a lot, Dave and Bill.  So does it seem safe
>> to say, then, that folks on 2.3 can upgrade if it ever becomes
>> necessary to use one of the tools?
>> As for Python 2.4, I haven't been following the discussion as closely
>> since it seems to affect Chromium developers more.  Can someone
>> summarize the state of the discussion there -- does it seem like there
>> is a consensus?
>> --Chris
> _______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

More information about the webkit-dev mailing list