[webkit-dev] A proposal for "Platform Mechanisms"

Anders Carlsson andersca at apple.com
Wed Jun 16 18:05:46 PDT 2010

On Jun 16, 2010, at 5:57 PM, Simon Fraser wrote:


> I don't think having "mechanism" in all the names here really adds much. Other than letting me know that these classes are all for some kind of port-specific specialization, it doesn't communicate anything about what they do. Maybe "handler" would be a slightly better word to use?

We've thrown many different terms around, "platform override", "platform policy" and "platform mechanism". I'm not entirely happy with any of them.

> Also, PlatformMechanism is a Factory, and should be named accordingly. Or maybe it's a Source of clients/mechanisms.

Good point, it is a factory.

> Do these calls return a new instance each time, or a singleton, or does it not matter?

See my reply to Darin, they're expected to be singletons.

> These feel like the OOP equivalent of ChromeClient; can we use that to inform naming?


- Anders

More information about the webkit-dev mailing list