[webkit-dev] Name nitpick: "layout tests"
rniwa at webkit.org
Thu Jul 29 11:09:19 PDT 2010
On Thu, Jul 29, 2010 at 10:59 AM, Darin Adler <darin at apple.com> wrote:
> The directory should be eventually be named Tests or WebKitTests or
> RegressionTests. Eric Seidel can probably remember talking this over with me
> the day after we added the LayoutTests directory; sorry that I never fixed
This sounds like an easy fix compared to converting all the existing tests.
I do like the idea of renaming it since some tests aren't really testing
As a first step, I suggest we make the test controller object available
> under its new name, and start using that name in new tests. Once we convert
> all the tests, we can drop the layoutTestController name entirely.
But I'm not sure if converting all the existing tests is feasible or worth
the effort. Is there any practical problem other than being semantically
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev