[webkit-dev] Name nitpick: "layout tests"
darin at apple.com
Thu Jul 29 10:59:33 PDT 2010
WebKit regression tests are in a directory named LayoutTests. The object the tests uses to do special test-specific operations is "layoutTestController". Both of these names are unwanted baggage, left over from when the test machinery was only good for testing layout.
The directory should be eventually be named Tests or WebKitTests or RegressionTests. Eric Seidel can probably remember talking this over with me the day after we added the LayoutTests directory; sorry that I never fixed it!
The object should be named testController, or perhaps someone can think of an even better name. A super-short one would probably be OK; the only practical problem is that we don’t want to choose a name that is likely to conflict with something we’ll add to HTML5 in the future. (I would have used the phrase “the web platform” instead of HTML5, which would be way better for pedants, but I think it would confuse others.)
While we may be stuck with the current names for some time, we should not introduce new uses of the word "layout" in the context of our regression test machinery.
That’s why the script is named run-webkit-tests, not run-layout-tests. I renamed that one in time, before we went wide with the WebKit project. It’s my fault we didn’t rename those other things sooner.
As a first step, I suggest we make the test controller object available under its new name, and start using that name in new tests. Once we convert all the tests, we can drop the layoutTestController name entirely.
More information about the webkit-dev