[webkit-dev] Removing support for the -khtml- (and -apple-?) vendor prefixes

David Hyatt hyatt at apple.com
Mon Jul 12 13:28:26 PDT 2010

On Jul 12, 2010, at 12:09 PM, Maciej Stachowiak wrote:

> The reason for these is historical. Originally, we didn't use a separate vendor prefix for WebKit, just -khtml. Later we changed to -apple.

That's not quite right.  Originally we just had -khtml- for CSS extensions, and then we used -apple- for features that we were Apple-specific, i.e., that we knew nobody else would care about.  Those features include Dashboard regions and Safari RSS line clamping).  Eventually we just decided to merge both into a common prefix, but we wanted to keep the old property names working for compatibility.   It was convenient to just map both to -webkit- rather than actually checking the specific property names and only supporting either -khtml- or -apple-.

My recommendation would be as follows:
(1) Drop support for -khtml- completely.
(2) Continue to support -apple- for -apple-dashboard-region and -apple-line-clamp only.

(hyatt at apple.com)

More information about the webkit-dev mailing list