[webkit-dev] More thoughts on cleaning up the root directory

Adam Barth abarth at webkit.org
Mon Dec 27 11:14:29 PST 2010

Thanks fora ll your feedback.  Responses inline.

On Mon, Dec 27, 2010 at 2:06 AM, Kenneth Rohde Christiansen
<kenneth.christiansen at gmail.com> wrote:
> So we have PerformanceTests, RegressionTests and manual. Why not
> ManualTests?

My thought process was that these are manual regression tests, just
like the HTTP tests are HTTP regression tests (and are handled
specially by run-webkit-tests).

> Is it really a good idea to move platform out of WebCore? Lots of stuff
> there seems quite WebCore related.

There seem to be a couple people who aren't sold on moving platform
out of WebCore.  It sounds like we should hold off on doing that and
discuss it separately down the road.

On Mon, Dec 27, 2010 at 2:47 AM, Hajime Morita <morrita at google.com> wrote:
>>  Platform/ (was WebCore/platform)
> I'd like to keep platform directory under WebCore if there is no strong reason.

Ok.  I think different people have slightly different ideas about what
should go into this folder.  That sounds like a complex topic that we
might need to discuss more later.

On Mon, Dec 27, 2010 at 3:58 AM, Patrick Gansterer <paroga at paroga.com> wrote:
> Adam Barth:
>> There are a bunch of build-system related files that are currently in
>> the root.  I'm not sure whether we should leave them in there or move
>> them into Sources somewhere.  I'm tempted to put them into Sources so
>> that Sources is self-contained package of all the stuff you need to
>> build WebKit.  That said, having a top-level Makefile that kicks off
>> the whole process also seems reasonable.
> If we keep a top level Makefile we also need to keep all "== UNSURE ==" files.
> IMHO it's better to move all build related stuff into Sources. Then you only need the Sources directory to build WebKit.

That makes sense to me.

>> PerformanceTests/
>>  PageLoad/ (was PageLoadTests)
>>  SunSpider/
>>  HTMLParser/ (was WebCore/benchmarks/parser)
> A XML parser benchmark will land soon (bug 51612), so "Parser" might be a better name instead of "HTMLParser".

Ok.  :)

On Mon, Dec 27, 2010 at 4:49 AM, Zoltan Herczeg
<zherczeg at inf.u-szeged.hu> wrote:
> Like it. I only have a few questions:
> * Where would the build (WebKitBuild) directory would go? Perhaps a Build/
> would fit in the root directory.

Yes.  I have a patch ready to land that renames WebKitBuild to Build.
Landing that patch is slightly tricky because it requires a buildbot
master restart.

> * Some manual-tests belong to the regression tests, and some are belong to
> the performance test. Would be good to separate them.

Interesting.  I might need some help figuring out which are which.

> * I think the build related files could go to Sources/ (no need an extra
> level)

Ok.  Several other folks have commented with the same perspective.

On Mon, Dec 27, 2010 at 10:19 AM, Mark Rowe <mrowe at apple.com> wrote:
> WebKitLibraries contains precompiled binaries rather than source code.
>  Mixing source and precompiled binaries under the Sources directory will
> make it difficult to make the necessary changes down the road to allow
> removing the forwarding headers mechanism.  We should keep the two types of
> content separate.

Maybe we should rename WebKitLibraries to Libraries and leave it in
the root directory?  I'm not sure I fully understand the coupling
between where the libraries are and the forwarding headers, but I
believe you.  :)

On Mon, Dec 27, 2010 at 10:37 AM, Mark Rowe <mrowe at apple.com> wrote:
> Can someone also elaborate on why "Sources" was chosen as the top-level
> directory name rather than "Source"? "Source code" is a mass noun so it's
> unclear why the abbreviated form of "source" would be pluralized in this
> manner. Referring to source code as "source" appears to be very common, but
> I've never encountered "sources" used in this manner. It reads very
> awkwardly to me.

That's just the name that Darin used in his email proposing the new
layout.  If folks would prefer Source, now is a good time to make that
change because there's only a handful of directories there now.

Traditionally, in other open-source projects, other folks call this
directory "src".  For example, that's what Cassandra uses:


However, using a real English word seems more aligned with WebKit's
no-abbreviation culture.


More information about the webkit-dev mailing list