[webkit-dev] Bools are strictly worse than enums

Ryosuke Niwa rniwa at webkit.org
Fri Dec 3 14:15:03 PST 2010

On Fri, Dec 3, 2010 at 1:55 PM, Nico Weber <thakis at chromium.org> wrote:

> Out of curiosity, what do people think of
> doSomethingElse(/*paramName=*/true);
> when calling an existing function that takes a bool?

Why don't we just change it to take enum instead?  Adding a comment to
repeat the argument name in call sites seems to contradict all other coding
principles we have in WebKit.

- Ryosuke
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20101203/314f836a/attachment.html>

More information about the webkit-dev mailing list