[webkit-dev] Bools are strictly worse than enums

Eric Seidel eric at webkit.org
Fri Dec 3 13:28:58 PST 2010


It seems to me, that using bool types for function arguments is strictly
worse than using an enum.  An enum is always clearer and can be easily
casted to a bool if needed.

doSomething(something, false);

Is much less readable than:

doSomething(something, AllowNetworkLoads);


Do any C++ gurus have further information to add here?  Is my (simple)
analysis here incorrect?  If not, seems we should forbid boolean values in
multi-argument methods/constructors in our style and add checks to
check-webkit-style to prevent further introduction of these confusing
callsites.

-eric
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20101203/ad36d46d/attachment.html>


More information about the webkit-dev mailing list