[webkit-dev] Misplaced files

Jeremy Orlow jorlow at chromium.org
Tue Aug 31 03:02:48 PDT 2010

On Mon, Aug 30, 2010 at 5:17 PM, Darin Fisher <darin at chromium.org> wrote:

> On Mon, Aug 30, 2010 at 9:11 AM, Maciej Stachowiak <mjs at apple.com> wrote:
>> On Aug 30, 2010, at 8:36 AM, Darin Fisher wrote:
>> On Mon, Aug 30, 2010 at 12:18 AM, Adam Barth <abarth at webkit.org> wrote:
>>> On Fri, Aug 27, 2010 at 8:12 PM, Maciej Stachowiak <mjs at apple.com>
>>> wrote:
>>> > Yes. The file-related stuff should all be in one directory, I think.
>>> Ok.  I moved the files from WebCore/html to WebCore/fileapi.
>>> On Aug 27, 2010, at 6:19 PM, Kinuko Yasuda wrote:
>>> > We have bunch of FileSystem (which is a part of File API) related files
>>> in
>>> > WebCore/storage/.
>>> > Maybe we should move them to the new directory too?
>>> Are these the files you're talking about?
>>> WebCore/storage/DOMFilePath.cpp
>>> WebCore/storage/DOMFilePath.h
>>> WebCore/storage/DOMFileSystem.cpp
>>> WebCore/storage/DOMFileSystem.h
>>> WebCore/storage/DOMFileSystem.idl
>>> WebCore/storage/FileEntry.cpp
>>> WebCore/storage/FileEntry.h
>>> WebCore/storage/FileEntry.idl
>>> WebCore/storage/FileSystemCallback.h
>>> WebCore/storage/FileSystemCallback.idl
>>> WebCore/storage/FileSystemCallbacks.cpp
>>> WebCore/storage/FileSystemCallbacks.h
>>> WebCore/storage/LocalFileSystem.cpp
>>> WebCore/storage/LocalFileSystem.h
>>> I'm happy to move them to WebCore/fileapi, but I'm also happy for you to
>>> do it.
>>> Thanks,
>>> Adam
>> How about just moving everything into WebCore/storage?  This is all
>> storage-related stuff.
>> I think the File API is large enough to deserve its own directory. In
>> fact, it might be worth splitting up the remaining contents of the storage
>> directory too. It is confusing to have large but almost entirely separate
>> APIs all piled into one directory. It is true they are all
>> "storage-related", but that is a pretty broad theme, and LocalStorage, SQL
>> Storage, Indexed DB and File API have little or no interaction with each
>> other.
>> Regards,
>> Maciej
> That's fair.  Plus, there are a lot of files in there already.

What names should we use?

Like WebSockets, I think the "web" part is pretty important to keep people
from getting confused.  'websqldatabase' seems a bit long though.
 'websqldb' maybe?

Currently we call this "Dom Storage" throughout the codebase (including in
the ENABLE macro), so we may want to call it "domstorage".  Like WebSockets
and WebSQLDatabase, I think "storage" with no prefix seems like a generic
storage directory so we should probably call it "webstorage" if "domstorage"
isn't acceptable.

Indexed Database API:
"IndexedDB" is what it's commonly called, so a directory of "indexeddb"
seems like the way to go.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20100831/6309eef4/attachment.html>

More information about the webkit-dev mailing list