[webkit-dev] Name nitpick: "layout tests"

Aaron Boodman aa at google.com
Tue Aug 3 13:24:02 PDT 2010

On Mon, Aug 2, 2010 at 9:40 AM, Darin Fisher <darin at chromium.org> wrote:
> On Mon, Aug 2, 2010 at 7:33 AM, Dan Bernstein <mitz at apple.com> wrote:
>> On Aug 2, 2010, at 4:28 AM, Alexey Proskuryakov wrote:
>> >
>> > 29.07.2010, в 10:59, Darin Adler написал(а):
>> >
>> >> The directory should be eventually be named Tests or WebKitTests or
>> >> RegressionTests.
>> >
>> >
>> > Ideally, the directory will have a unique first letter for better tab
>> > completion - so WebKitTests is a poor option from that point of view. I like
>> > the other two.
>> Tests collides with Tools (which is what WebKitTools should be renamed
>> to).
> That sounds like a vote for RegressionTests

I know I'm new around here, but my .02: This seems like a lot of busy
work that will never really complete. We'll end up with "LayoutTests"
in some places and "RegressionTests" in others, indefinitely. It will
be even more messy than having the bad name consistently. Keep in mind
that there are places that refer to "WebKit's LayoutTests" that aren't
even under the WebKit project's control:


It seems simpler and better to me to just have a note on the page on
webkit.org that talks about LayoutTests describing the origins of the
name and let sleeping dogs lie.

- a

More information about the webkit-dev mailing list