[webkit-dev] policyBaseURL and mainDocumentURL

Adam Barth abarth at webkit.org
Thu May 21 13:39:34 PDT 2009

On Thu, May 21, 2009 at 10:54 AM, Darin Adler <darin at apple.com> wrote:
> On May 20, 2009, at 11:22 PM, Adam Barth wrote:
>> I'm trying to sort out all the security / privacy URLs we have, and I'm a
>> bit puzzled by ResourceRequestBase::mainDocumentURL and
>> Document::policyBaseURL.  They both seem connected to third-party cookie
>> blocking.  Are they the same?
> I believe they are two different names for what should be the same thing.
> The policy base URL was the older name, and main document URL the newer.

The new name is really confusing.  When I looked into where the URL
comes from, it's not always the mainDocumentURL.  Sometimes it's the
URL of the request itself!

If it's really the same thing, maybe we should call it
firstPartyURLForCookies.  :)


More information about the webkit-dev mailing list