[webkit-dev] InlineBox::m_isSVG

David Hyatt hyatt at apple.com
Mon Jun 22 10:12:11 PDT 2009

On Jun 21, 2009, at 11:18 PM, Roland Steiner wrote:

> Hi Dave,
> as I will probably need to special-case height() for ruby InlineBox  
> objects in the same way as is done for SVG boxes (still ironing out  
> the details, though), making height() virtual was exactly my intent.  
> I would have thought that the performance cost of a virtual call to  
> height() would be offset by being able to remove the isSVG()  
> condition inside (and later a potential isRuby() condition as well).
> Now if there are actual performance reasons for that bit and/or for  
> having height() be non-virtual, then I may need to find another  
> solution.
> Thanks,
> Roland

You could probably just rename the m_isSVG bit to be something like  
m_calculatesHeight, and then the virtual method that height() calls  
when that is true could be renamed to be more general.

(hyatt at apple.com)

More information about the webkit-dev mailing list