[webkit-dev] test scripts
chris.jerdonek at gmail.com
Mon Dec 28 19:14:31 PST 2009
Last night on IRC there was a brief discussion of the test scripts:
how they should be divided in the future and what they should be
called. These scripts are in WebKitTools/Scripts.
I believe we currently have at least (correct me if I'm wrong)--
run-webkit-unittests (tests Python scripts)
I also have a patch to add a script to test some Perl functionality.
Maciej mentioned that he thinks it's useful for scripts to begin with
an action word (i.e. a verb). However, we currently have many scripts
(not just testing scripts) that begin with the generic word "run."
Going forward, how would people feel about giving new test scripts
names that begin with the word "test"? For example--
Separate from this question, I think it would be great if one of those
participating last night (or anyone else) could share their vision of
how they think our tests should be divided up in the mid to long-term.
This can include new tests that we haven't written yet, but hope to.
More information about the webkit-dev