[webkit-dev] [webkit-changes] [42699] trunk/WebCore

Alexey Proskuryakov ap at webkit.org
Mon Apr 20 23:11:48 PDT 2009

21.04.2009, в 9:59, ggaren at apple.com написал(а):

>         Renamed "*InlineEventListener*" =>  
> "*AttributeEventListener*", and
>         "isInline" => "isAttribute".
> -EventListener* Node::getInlineEventListener(const AtomicString&  
> eventType) const
> +EventListener* Node::getAttributeEventListener(const AtomicString&  
> eventType) const

I think that per our coding style guidelines, this function should be  
named attributeEventListener():

6. Precede setters with the word "set". Use bare words for getters.  
Setter and getter names should match the names of the variables being  

- WBR, Alexey Proskuryakov

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20090421/4b02b2a9/attachment.html>

More information about the webkit-dev mailing list