[webkit-dev] bindings layer should have a consistent way of getting at named items in collections
ojan at chromium.org
Tue Oct 14 15:15:44 PDT 2008
I currently see nameGetter, namedItem
and getNamedItem in a number of different files that all currently
have custom bindings that normalize to a nameGetter function.
Can we just have all the collection types normalize on a single name
for this function? It would mean that much of this custom binding
could be avoided.
I'm running into this with Chromium as I am trying to replace our
PluginArray and MimeTypeArray with WebKit's. This is messing with our
templates that currently just use
(although could just as easily use nameGetter if that's preferred).
The big differences with our MimeTypeArray implementation is that it kept a
Vector of MimeTypes, returned raw pointers and used namedItem instead of
nameGetter. It would be great if we could unify these.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev