[webkit-dev] Building Webkit

Khanna Piyush-A21612 piyush at motorola.com
Fri Mar 28 05:40:16 PDT 2008

I'm running into a basic configuration problem while trying to build
webkit on win32

*	I followed the steps outlined at
http://webkit.org/building/tools.html and

	*	I now have VC++ 2005 Express (+ SP1), Windows Platform
SDK (with steps 2 & 3 followed), Cygwin, and Quicktime SDK installed
	*	I have checked out the latest Webkit trunk source code
into C:\cygwin\home\a21612\WebKit
	*	I have placed WebKitSupportLibrary.zip at

Building issues:

*	When I run the "WebKit\WebKitTools\Scripts\build-webkit"
command, I get the following error:

C:\cygwin\home\a21612>perl WebKit\WebKitTools\Scripts\build-webkit
The system cannot find the path specified.
Unsupported platform, can't determine built library locations. at
/a21612/WebKit/WebKitTools/Scripts/webkitdirs.pm line 367.

*	When I run the
"WebKit\WebKitTools\Scripts\set-webkit-configuration" command, I get the
following error:

WebKit\WebKitTools\Scripts\set-webkit-configuration -
The system cannot find the path specified.
The syntax of the command is incorrect.
Died at WebKit\WebKitTools\Scripts\set-webkit-configuration line 39.

*	I am getting the above errors while trying to build using win32
command-line. When I try to open the
project in VC++ 2005 Express, I get the following error:

The following error has occurred during XML parsing:
Line: 25
Column: 5
Error Message:
Property sheet file '$(WebKitLibrariesDir)\tools\vsprops\common.vsprops'
was not found or failed to load.
The file
' has failed to load.
I'm not sure where to configure the $(WebKitLibrariesDir)...in the
environment path?
Glad if anyone could help.
Thanks in advance!
Best Regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.webkit.org/pipermail/webkit-dev/attachments/20080328/5d9f5a62/attachment.html

More information about the webkit-dev mailing list