[webkit-dev] Query on running the test scripts

David Kilzer ddkilzer at webkit.org
Thu Jul 10 06:36:38 PDT 2008

The run-javascriptcore-tests script attempts to build JavaScriptCore and the testkjs/jsc tool before running the actual tests.  If you haven't taught webkitdirs.pm how to build for your platform, it's not going to work.

The line in the script that runs the actual test is this line:

my $result = system "perl", "jsDriver.pl", "-e", "squirrelfish", "-s", jscPath($productDir), "-f", "actual.html", @jsArgs;

Try running that command by itself (I don't think you need any @jsArgs by default) to see if that works.


On Thu, 7/10/08, Gargi Varun-DFXR46 <DFXR46 at motorola.com> wrote:

> Hi All
> We are trying to test javascriptcore using the scripts that
> we have in
> Dir \WebKit\WebKitTools\Scripts. 
> We have build the webkit on Symbian UIQ.  
> when we try running  a script
> "run-javascriptcore-tests"  from command
> prompt it gives some errors as follows 
> The system cannot find the path specified.
> The system cannot find the path specified.
> Building not defined for this platform!
> Compiling testkjs failed!
> Is there any thing more needed to make these scripts run.
> We tried it on Cygwin also still the same errors.
> Thanks
> Varun_______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

More information about the webkit-dev mailing list