[webkit-dev] renaming ASSERT macro
joerg.bornemann at trolltech.com
Tue Jul 1 01:45:02 PDT 2008
Darin Adler wrote:
>> Well, this is a small change but also a very bad idea. Not because of
>> compilation time, but because of the crappy Windows headers which define
>> *a* *lot* of global stuff. E.g. the XSLT parser of WebKit won't build
>> because there's a "#define ERROR <somenumber>" which breaks an enum
>> definition. Or think of the famous MIN / MAX definitions, which drive
>> every crossplatform developer insane.
> OK. Lets #undef those things.
This solution is easy to do, leads to the smallest source diff but is a
very dirty hack, which will lead to problems on WinCE, because we will
include windows.h in public headers. One survival rule of Windows
developers is: only include windows.h when it is really needed.
So what's your argument against the clean solution (renaming)?
More information about the webkit-dev