[webkit-dev] webkit glib DOM bindings demo code

Christian Dywan christian at twotoasts.de
Mon Dec 8 07:12:59 PST 2008

Am Mon, 8 Dec 2008 14:03:46 +0000
schrieb "Luke Kenneth Casson Leighton" <lkcl at lkcl.net>:
> this is all in c.
> it's the same sort of thing in python with pywebkitgtk -  except
> _slightly_ less messy. in pyjamas-desktop, once i get round to it, the
> messy names will go away, and revert back to
> moreSensibleNamingSchemes.
> i'm recommending to change the naming schemes back to more sensible
> ones than_this_stupid_looking_one, on the basis that the convention
> has already been decided by netscape, and is now a specification.
> mozilla doesn't do this (in xul interface bindings), so why it's being
> done here is ... it just makes things _bizarre_.
> thoughts, anyone?

Hey Luke,

I suggest you accept the fact that coding style and naming are a matter
of preference and convention. A Glib specific binding should really
adapt the API style, even if there coding style in the implementation
may differ. If JavaScript sources dominantly use camelCase that's what
functions in JavaScript should and usually do conform to. If Glib
interfaces dominantly use under_scores then that's what functions in
Glib libraries should and usually do conform to.

It's as simple as that. Convincing anyone of your preferred coding
and naming style is not going to help. :)


More information about the webkit-dev mailing list