[webkit-dev] Building the Qt version on Linux

sea mitigosea at gmail.com
Fri Apr 11 02:25:12 PDT 2008


I am very new to this WebKit technology. I have tried to build Webkit using

I have taken the source from WebKit Nightly Builds: "*WebKit
* was built on 11 April 2008 and is a 8.9 MB download."

I got this building error of libQtWebKit shared library.

tmp/chartables.o:(.rodata+0x0): multiple definition of
tmp/pcre_tables.o:(.rodata+0xa0): first defined here

The error is obvious because JavaScriptCore/pcre/pcre_tables.cpp has
included the generated "C" file (#include "chartables.c")

After commenting out that, build was successful. I just wonder, how that
simple mistake is ignored.

I tried to run Qt Webkit.

./WebKitTools/Scripts/run-webkit-tests --qt

It opens up the main window but I could not browse or do anything with it.
Is this expected? I am pretty interested to help developing WebKit using Qt.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.webkit.org/pipermail/webkit-dev/attachments/20080411/e555cf51/attachment.html

More information about the webkit-dev mailing list