[webkit-dev] Bus error while building WebKit on Mac

David D. Kilzer ddkilzer at kilzer.net
Mon Oct 8 07:49:45 PDT 2007

Hi Song,

What version of Xcode and gcc do you have installed?  Run "gcc --version" in a
Terminal window to check the gcc version, or launch Xcode and choose "About
Xcode" from the Xcode menu.

If you are using Xcode 2.4.1 or this version of gcc:

powerpc-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5367)

please file a bug on https://bugreport.apple.com/ (you may create a free
"online" account using https://connect.apple.com/) or file a bug on

When filing the bug, please include the following information:

- The versions of Xcode and gcc you're using (see above).
- The entire gcc command used to compile the file (with the resulting error
- The file created by rerunning the entire failing gcc command with the "-E"
switch added and the output filename changed from ".o" to ".i".  Note that you
may have to fix the path to WebKitPrefix.h if the compiler complains about not
finding the file.
- [Optional] A system profile (*.spx) file from the System Profiler

Also, please reply to this message with the Radar bug number
(bugreport.apple.com) or the Bugzilla bug number (bugs.webkit.org) if you do
file a bug.



Song Yuan <song at yuan.se> wrote:

> Hi,
> I've got the required packages installed on my Mac and tried to build
> WebKit, but I got the same error on two different snapshots of the
> source code. It's "internal compiler error: Bus error" from line 2662
> of "WebHTMLView.mm". I pasted the last few lines of log message below:
> ----------------------------------
> kwzrnsixmxdf/WebKitPrefix.h -c
> /Users/song/WebKit/WebKit/WebView/WebHTMLView.mm -o
> /Users/song/WebKit/WebKit/WebView/WebHTMLView.mm: In function 'void
> -[WebHTMLView viewDidMoveToWindow](WebHTMLView*, objc_selector*)':
> /Users/song/WebKit/WebKit/WebView/WebHTMLView.mm:2662: internal
> compiler error: Bus error
> Please submit a full bug report,
> with preprocessed source if appropriate.
> See <URL:http://developer.apple.com/bugreporter> for instructions.
> {standard input}:27527:FATAL:.abort  detected.  Assembly stopping.
> -----------------------------------
> I searched the mailing list archive and found another guy had similar
> error before, but not seemed to be solved (The response with the
> quoted message is at
> http://lists.macosforge.org/pipermail/webkit-dev/2006-June/001066.html).
> Could any guys please give some clues on this? Thanks a lot!
> /Song

More information about the webkit-dev mailing list