[webkit-dev] WebKit still doesn't compile

Yael.Aharon at nokia.com Yael.Aharon at nokia.com
Sun Jun 17 10:01:51 PDT 2007

A quick solution is to manually copy the folder c:\cygwin\webkit\javascriptcore\wtf to c:\WebKitBuild\Include\JavaScriptCore.
It fixed this problem for me.

-----Original Message-----
From: webkit-dev-bounces at lists.webkit.org [mailto:webkit-dev-bounces at lists.webkit.org] 
Sent: Sunday, June 17, 2007 11:41 AM
To: webkit-dev at lists.webkit.org
Subject: Re: [webkit-dev] WebKit still doesn't compile

On Wed, 13 Jun 2007, Oliver Hunt wrote:

> You should be following the instructions at 
> http://webkit.org/building/build.html
> To build WebKit:
> ~/WebKit/WebKitTools/Scripts/build-webkit

I tried this way as well, still it doesn't compile.
WEBKITLIBRARIESDIR and WEBKITOUTPUTDIR are set correctly (see log file), still there are includes which are not found. My assumption is that there are some include paths missing. I managed to build the Linux/Qt version, but for demonstation purposis I need an implementation of WebKit running on Windows, and no, Safari won't work.

Greetings from Germany,
|  _______       |
| (  /\          | Every kiss means pain, pain and secrets to me
|__)v\/lli a.k.a.| Is it permanence that love shattered pride.
|Sven Oliver Moll|   -- The Eternal Afflict, "San Diego (The Tragical)"

More information about the webkit-dev mailing list