[webkit-dev] Lost: Building webkit: Build finished, but starting Safari only gives an error window

Paul Bakker pgbakker at gmail.com
Tue Jul 17 14:01:38 PDT 2007

Ok, been trying and trying, but can get it to work.


I think I followed all the instructions on
http://webkit.org/building/tools.html to install all dev tools on windows, I
got the sourcecode and try to build it.


The Cygwin console goes back to the prompt after quite a while, but when I
then try to start Safari, Safari doesn't start and I get the Windows Error
popup, asking me if I want to send an error Report to MS (which I do not
want to do at this point :-) )


In Cygwin I did the following commands in order:

-          svn cleanup Webkit

-          WebKit/WebKitTools/Scripts/update-webkit (I moved the content of
the TAR file to the appropriate dir first offcourse)

-          WebKit/WebKitTools/Scripts/build-webkit (also tried with the
debug option in)

-          WebKit/WebKitTools/Scripts/run-safari


After the last command, as said before, I get the windows Error window
asking me if I want to send an error report.


Safari never starts..


I tried to find error logs.. All I found so far are some errors here and
there in the builgLog.html. The Cygwin console also does not display any


As far as I can figure out, I configured the paths in Visual Studio Express
correctly as well.


Where to go from here..


Tnx in advance






-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.macosforge.org/pipermail/webkit-dev/attachments/20070717/3a9ad99c/attachment.html

More information about the webkit-dev mailing list