[webkit-dev] Thoughts on WebKit/WebCore refactoring

Darin Adler darin at apple.com
Fri Dec 23 13:03:23 PST 2005

On Dec 23, 2005, at 11:07 AM, Maciej Stachowiak wrote:

> On Dec 23, 2005, at 8:24 AM, John Sullivan wrote:
>> "DocumentController" seems like a problematic name because it's  
>> too close to NSDocumentController, yet it's very much not  
>> parallel. Safari has one NSDocumentController per window, but  
>> there's one DocumentController per web frame.
> True, but Document (in the DOM) and NSDocument are non-parallel in  
> exactly the same way. The root of the problem is overloading of the  
> AppKit and DOM senses of the term "document". I could call the  
> WebCore one FrameController (or even just Frame) but I think that  
> would be less clear about it's actual relationship to the document.

I think that Page and Frame might be great names for these controller  
object classes; perhaps even better than PageController and  

The plan sounds good -- a key part of this is how bridging will work  
for the policy-delegate type things.

I'd like to see any new bridging done with C if possible as opposed  
to C++ or Objective-C.

     -- Darin

More information about the webkit-dev mailing list