[webkit-changes] [WebKit/WebKit] b0c5f4: [text-wrap] Rename InlineContentBalancer to Inline...

Alan Baradlay noreply at github.com
Mon Sep 16 16:46:59 PDT 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: b0c5f40cc599ff52d433e45f2c5691d0173cd0f8
      https://github.com/WebKit/WebKit/commit/b0c5f40cc599ff52d433e45f2c5691d0173cd0f8
  Author: Alan Baradlay <zalan at apple.com>
  Date:   2024-09-16 (Mon, 16 Sep 2024)

  Changed paths:
    M Source/WebCore/Sources.txt
    M Source/WebCore/WebCore.xcodeproj/project.pbxproj
    R Source/WebCore/layout/formattingContexts/inline/InlineContentBalancer.cpp
    R Source/WebCore/layout/formattingContexts/inline/InlineContentBalancer.h
    A Source/WebCore/layout/formattingContexts/inline/InlineContentConstrainer.cpp
    A Source/WebCore/layout/formattingContexts/inline/InlineContentConstrainer.h
    M Source/WebCore/layout/formattingContexts/inline/InlineFormattingContext.cpp

  Log Message:
  -----------
  [text-wrap] Rename InlineContentBalancer to InlineContentConstrainer
https://bugs.webkit.org/show_bug.cgi?id=279784

Reviewed by Alan Baradlay.

Original patch by David Tran.

This is in preparation for implementing 'text-wrap: pretty'

* Source/WebCore/Sources.txt:
* Source/WebCore/WebCore.xcodeproj/project.pbxproj:
* Source/WebCore/layout/formattingContexts/inline/InlineContentConstrainer.cpp: Renamed from Source/WebCore/layout/formattingContexts/inline/InlineContentBalancer.cpp.
(WebCore::Layout::computeCost):
(WebCore::Layout::containsTrailingSoftHyphen):
(WebCore::Layout::containsPreservedTab):
(WebCore::Layout::cannotConstrainInlineItem):
(WebCore::Layout::InlineContentConstrainer::InlineContentConstrainer):
(WebCore::Layout::InlineContentConstrainer::initialize):
(WebCore::Layout::InlineContentConstrainer::computeParagraphLevelConstraints):
(WebCore::Layout::InlineContentConstrainer::balanceRangeWithLineRequirement):
(WebCore::Layout::InlineContentConstrainer::balanceRangeWithNoLineRequirement):
(WebCore::Layout::InlineContentConstrainer::inlineItemWidth const):
(WebCore::Layout::InlineContentConstrainer::shouldTrimLeading const):
(WebCore::Layout::InlineContentConstrainer::shouldTrimTrailing const):
(WebCore::Layout::InlineContentConstrainer::SlidingWidth::SlidingWidth):
(WebCore::Layout::InlineContentConstrainer::SlidingWidth::width):
(WebCore::Layout::InlineContentConstrainer::SlidingWidth::advanceStart):
(WebCore::Layout::InlineContentConstrainer::SlidingWidth::advanceStartTo):
(WebCore::Layout::InlineContentConstrainer::SlidingWidth::advanceEnd):
(WebCore::Layout::InlineContentConstrainer::SlidingWidth::advanceEndTo):
(WebCore::Layout::InlineContentConstrainer::computeBreakOpportunities const):
* Source/WebCore/layout/formattingContexts/inline/InlineContentConstrainer.h: Renamed from Source/WebCore/layout/formattingContexts/inline/InlineContentBalancer.h.
* Source/WebCore/layout/formattingContexts/inline/InlineFormattingContext.cpp:
(WebCore::Layout::InlineFormattingContext::layout):

Canonical link: https://commits.webkit.org/283731@main



To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications


More information about the webkit-changes mailing list