[webkit-changes] [WebKit/WebKit] f14972: [JSC] Remove unnecessary VM association logic from...

Yijia Huang noreply at github.com
Mon Sep 2 14:13:38 PDT 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: f14972e4ee63f72be4b6573546705c1527330700
      https://github.com/WebKit/WebKit/commit/f14972e4ee63f72be4b6573546705c1527330700
  Author: Yijia Huang <yijia_huang at apple.com>
  Date:   2024-09-02 (Mon, 02 Sep 2024)

  Changed paths:
    M Source/JavaScriptCore/runtime/VM.cpp
    M Source/JavaScriptCore/runtime/WaiterListManager.cpp
    M Source/JavaScriptCore/runtime/WaiterListManager.h

  Log Message:
  -----------
  [JSC] Remove unnecessary VM association logic from Waiter and simplify WaiterListManager
https://bugs.webkit.org/show_bug.cgi?id=278930
rdar://135021931

Reviewed by Keith Miller and Mark Lam.

The patch removes the unnecessary association of VM with Waiter instances
in WaiterListManager. This includes eliminating the setVM and clearVM
methods and related assertions that checked the VM association. The
synchronization logic is simplified by relying solely on the isOnList
state of the Waiter instead of managing the VM pointer. This change
reduces the complexity of the code and ensures that the WaiterListManager
handles synchronization more efficiently. Additionally, minor code cleanup
and renaming are performed for clarity.

* Source/JavaScriptCore/runtime/VM.cpp:
(JSC::VM::syncWaiter):
* Source/JavaScriptCore/runtime/WaiterListManager.cpp:
(JSC::WaiterListManager::waitSyncImpl):
(JSC::WaiterListManager::notifyWaiterImpl):
(JSC::WaiterListManager::unregister):
* Source/JavaScriptCore/runtime/WaiterListManager.h:
(JSC::WaiterList::takeFirst):

Canonical link: https://commits.webkit.org/283069@main



To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications


More information about the webkit-changes mailing list