[webkit-changes] [WebKit/WebKit] 8fbb39: Rename "Shape" to "LayoutShape"
Simon Fraser
noreply at github.com
Tue Oct 29 15:38:22 PDT 2024
Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 8fbb39e35ffb6435b5c00b1fd5b48d947f6986d6
https://github.com/WebKit/WebKit/commit/8fbb39e35ffb6435b5c00b1fd5b48d947f6986d6
Author: Simon Fraser <simon.fraser at apple.com>
Date: 2024-10-29 (Tue, 29 Oct 2024)
Changed paths:
M Source/WebCore/Headers.cmake
M Source/WebCore/Sources.txt
M Source/WebCore/WebCore.xcodeproj/project.pbxproj
M Source/WebCore/inspector/InspectorOverlay.cpp
M Source/WebCore/layout/floats/FloatingContext.cpp
M Source/WebCore/layout/floats/PlacedFloats.cpp
M Source/WebCore/layout/floats/PlacedFloats.h
M Source/WebCore/layout/formattingContexts/inline/InlineLineBuilder.cpp
M Source/WebCore/layout/layouttree/LayoutBox.cpp
M Source/WebCore/layout/layouttree/LayoutBox.h
M Source/WebCore/page/InteractionRegion.cpp
M Source/WebCore/rendering/RenderLayer.cpp
A Source/WebCore/rendering/shapes/BoxLayoutShape.cpp
A Source/WebCore/rendering/shapes/BoxLayoutShape.h
R Source/WebCore/rendering/shapes/BoxShape.cpp
R Source/WebCore/rendering/shapes/BoxShape.h
A Source/WebCore/rendering/shapes/LayoutShape.cpp
A Source/WebCore/rendering/shapes/LayoutShape.h
A Source/WebCore/rendering/shapes/PolygonLayoutShape.cpp
A Source/WebCore/rendering/shapes/PolygonLayoutShape.h
R Source/WebCore/rendering/shapes/PolygonShape.cpp
R Source/WebCore/rendering/shapes/PolygonShape.h
A Source/WebCore/rendering/shapes/RasterLayoutShape.cpp
A Source/WebCore/rendering/shapes/RasterLayoutShape.h
R Source/WebCore/rendering/shapes/RasterShape.cpp
R Source/WebCore/rendering/shapes/RasterShape.h
A Source/WebCore/rendering/shapes/RectangleLayoutShape.cpp
A Source/WebCore/rendering/shapes/RectangleLayoutShape.h
R Source/WebCore/rendering/shapes/RectangleShape.cpp
R Source/WebCore/rendering/shapes/RectangleShape.h
R Source/WebCore/rendering/shapes/Shape.cpp
R Source/WebCore/rendering/shapes/Shape.h
M Source/WebCore/rendering/shapes/ShapeOutsideInfo.cpp
M Source/WebCore/rendering/shapes/ShapeOutsideInfo.h
Log Message:
-----------
Rename "Shape" to "LayoutShape"
https://bugs.webkit.org/show_bug.cgi?id=282263
rdar://138857418
Reviewed by Alan Baradlay.
There are lots of things called "Shape": classes at the CSSValue level (ShapeValue), classes at the
style level (BasicShape), classes at the rendering level (BorderShape).
Using "Shape" for something that is only used at layout time is confusing, so rename it "LayoutShape",
and rename the subclasses accordingly.
No behavior change.
* Source/WebCore/Sources.txt:
* Source/WebCore/WebCore.xcodeproj/project.pbxproj:
* Source/WebCore/inspector/InspectorOverlay.cpp:
(WebCore::drawShapeHighlight):
* Source/WebCore/layout/floats/FloatingContext.cpp:
* Source/WebCore/layout/floats/PlacedFloats.cpp:
(WebCore::Layout::PlacedFloats::Item::Item):
* Source/WebCore/layout/floats/PlacedFloats.h:
(WebCore::Layout::PlacedFloats::Item::shape const):
* Source/WebCore/layout/formattingContexts/inline/InlineLineBuilder.cpp:
* Source/WebCore/layout/layouttree/LayoutBox.cpp:
(WebCore::Layout::Box::shape const):
(WebCore::Layout::Box::setShape):
* Source/WebCore/layout/layouttree/LayoutBox.h:
* Source/WebCore/page/InteractionRegion.cpp:
(WebCore::interactionRegionForRenderedRegion):
* Source/WebCore/rendering/RenderLayer.cpp:
* Source/WebCore/rendering/shapes/BoxLayoutShape.cpp: Renamed from Source/WebCore/rendering/shapes/BoxShape.cpp.
(WebCore::adjustRadiusForMarginBoxShape):
(WebCore::computeMarginBoxShapeRadius):
(WebCore::computeMarginBoxShapeRadii):
(WebCore::computeRoundedRectForBoxShape):
(WebCore::BoxLayoutShape::shapeMarginLogicalBoundingBox const):
(WebCore::BoxLayoutShape::shapeMarginBounds const):
(WebCore::BoxLayoutShape::getExcludedInterval const):
(WebCore::BoxLayoutShape::buildDisplayPaths const):
* Source/WebCore/rendering/shapes/BoxLayoutShape.h: Renamed from Source/WebCore/rendering/shapes/BoxShape.h.
* Source/WebCore/rendering/shapes/LayoutShape.cpp: Renamed from Source/WebCore/rendering/shapes/Shape.cpp.
(WebCore::createInsetShape):
(WebCore::createCircleShape):
(WebCore::createEllipseShape):
(WebCore::createPolygonShape):
(WebCore::physicalRectToLogical):
(WebCore::physicalPointToLogical):
(WebCore::physicalSizeToLogical):
(WebCore::LayoutShape::createShape):
(WebCore::LayoutShape::createRasterShape):
(WebCore::LayoutShape::createBoxShape):
* Source/WebCore/rendering/shapes/LayoutShape.h: Renamed from Source/WebCore/rendering/shapes/Shape.h.
(WebCore::LineSegment::LineSegment):
(WebCore::LayoutShape::lineOverlapsShapeMarginBounds const):
(WebCore::LayoutShape::shapeMargin const):
(WebCore::LayoutShape::lineOverlapsBoundingBox const):
* Source/WebCore/rendering/shapes/PolygonLayoutShape.cpp: Renamed from Source/WebCore/rendering/shapes/PolygonShape.cpp.
(WebCore::inwardEdgeNormal):
(WebCore::outwardEdgeNormal):
(WebCore::OffsetPolygonEdge::xIntercept const):
(WebCore::OffsetPolygonEdge::clippedEdgeXRange const):
(WebCore::circleXIntercept):
(WebCore::clippedCircleXRange):
(WebCore::PolygonLayoutShape::shapeMarginLogicalBoundingBox const):
(WebCore::PolygonLayoutShape::getExcludedInterval const):
(WebCore::PolygonLayoutShape::buildDisplayPaths const):
* Source/WebCore/rendering/shapes/PolygonLayoutShape.h: Renamed from Source/WebCore/rendering/shapes/PolygonShape.h.
(WebCore::PolygonLayoutShape::PolygonLayoutShape):
* Source/WebCore/rendering/shapes/RasterLayoutShape.cpp: Renamed from Source/WebCore/rendering/shapes/RasterShape.cpp.
(WebCore::MarginIntervalGenerator::MarginIntervalGenerator):
(WebCore::MarginIntervalGenerator::set):
(WebCore::MarginIntervalGenerator::intervalAt const):
(WebCore::RasterShapeIntervals::computeShapeMarginIntervals const):
(WebCore::RasterShapeIntervals::initializeBounds):
(WebCore::RasterShapeIntervals::buildBoundsPath const):
(WebCore::RasterLayoutShape::marginIntervals const):
(WebCore::RasterLayoutShape::getExcludedInterval const):
* Source/WebCore/rendering/shapes/RasterLayoutShape.h: Renamed from Source/WebCore/rendering/shapes/RasterShape.h.
(WebCore::RasterShapeIntervals::RasterShapeIntervals):
(WebCore::RasterShapeIntervals::bounds const):
(WebCore::RasterShapeIntervals::isEmpty const):
(WebCore::RasterShapeIntervals::intervalAt):
(WebCore::RasterShapeIntervals::intervalAt const):
(WebCore::RasterShapeIntervals::size const):
(WebCore::RasterShapeIntervals::offset const):
(WebCore::RasterShapeIntervals::minY const):
(WebCore::RasterShapeIntervals::maxY const):
* Source/WebCore/rendering/shapes/RectangleLayoutShape.cpp: Renamed from Source/WebCore/rendering/shapes/RectangleShape.cpp.
(WebCore::ellipseXIntercept):
(WebCore::RectangleLayoutShape::shapeMarginBounds const):
(WebCore::RectangleLayoutShape::getExcludedInterval const):
(WebCore::RectangleLayoutShape::buildDisplayPaths const):
* Source/WebCore/rendering/shapes/RectangleLayoutShape.h: Renamed from Source/WebCore/rendering/shapes/RectangleShape.h.
* Source/WebCore/rendering/shapes/ShapeOutsideInfo.cpp:
(WebCore::makeShapeForShapeOutside):
(WebCore::ShapeOutsideInfo::computedShape const):
* Source/WebCore/rendering/shapes/ShapeOutsideInfo.h:
Canonical link: https://commits.webkit.org/285863@main
To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications
More information about the webkit-changes
mailing list