[webkit-changes] [WebKit/WebKit] 0a3ec3: Rename RenderBox::computePreferredLogicalWidths va...
Sammy Gill
noreply at github.com
Wed Oct 23 15:05:15 PDT 2024
Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 0a3ec3085d58b35ff3c564e13cfdafe279c98975
https://github.com/WebKit/WebKit/commit/0a3ec3085d58b35ff3c564e13cfdafe279c98975
Author: Sammy Gill <sammy.gill at apple.com>
Date: 2024-10-23 (Wed, 23 Oct 2024)
Changed paths:
M Source/WebCore/rendering/RenderBox.cpp
M Source/WebCore/rendering/RenderBox.h
Log Message:
-----------
Rename RenderBox::computePreferredLogicalWidths variables to logical variations
https://bugs.webkit.org/show_bug.cgi?id=281993
rdar://138491867
Reviewed by Brent Fulgham.
RenderBox::computePreferredLogicalWidths has some parameters that are used to represent
logical sizes but they are not named as such. This small patch renames them to improve
the readability of this code.
minWidth -> minLogicalWidth
maxWidth -> maxLogicalWidth
borderAndPadding -> borderAndPaddingLogicalWidth
Also renamed the variables we create for the values we get from
computeMinMaxLogicalWidthFromAspectRatio to indicate these sizing constraints are
"transferred," ones that come from the aspect ratio to better align with spec language
and distinguish them from the newly named parameters as they represent different constraints.
* Source/WebCore/rendering/RenderBox.cpp:
(WebCore::RenderBox::computePreferredLogicalWidths):
* Source/WebCore/rendering/RenderBox.h:
Canonical link: https://commits.webkit.org/285624@main
To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications
More information about the webkit-changes
mailing list