[webkit-changes] [WebKit/WebKit] c92bcc: [JSC] improve readability of verboseOSR logging

Dan Hecht noreply at github.com
Fri Oct 18 08:21:02 PDT 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: c92bcccefbf6e50ddc6e1d6dc59585fc732c78d9
      https://github.com/WebKit/WebKit/commit/c92bcccefbf6e50ddc6e1d6dc59585fc732c78d9
  Author: Dan Hecht <dan.hecht at apple.com>
  Date:   2024-10-18 (Fri, 18 Oct 2024)

  Changed paths:
    M Source/JavaScriptCore/wasm/WasmOperations.cpp
    M Source/JavaScriptCore/wasm/WasmSlowPaths.cpp
    M Source/JavaScriptCore/wasm/WasmTierUpCount.h

  Log Message:
  -----------
  [JSC] improve readability of verboseOSR logging
https://bugs.webkit.org/show_bug.cgi?id=281699
rdar://138149217

Reviewed by Yijia Huang.

1) Tier-up to OMG top-level log statements were using the
"FunctionCodeIndex" as a prefix while the tier-up to BBQ logs
were using the FunctionSpaceIndex (via Callee::dump()). This
makes it really hard to grep for a particular wasm function
across phases. Make this consistent by prefixing top-level log
statements use Callee::dump() as the prefix (though I left
logging of the code index in these statements as well).

2) Indentation of secondary log statements is inconsistent. Make
it more consistent.

* Source/JavaScriptCore/wasm/WasmOperations.cpp:
(JSC::Wasm::shouldTriggerOMGCompile):
(JSC::Wasm::triggerOMGReplacementCompile):
(JSC::Wasm::doOSREntry):
(JSC::Wasm::JSC_DEFINE_NOEXCEPT_JIT_OPERATION):
* Source/JavaScriptCore/wasm/WasmSlowPaths.cpp:
(JSC::LLInt::jitCompileAndSetHeuristics):
(JSC::LLInt::jitCompileSIMDFunction):
(JSC::LLInt::WASM_SLOW_PATH_DECL):
* Source/JavaScriptCore/wasm/WasmTierUpCount.h:
(JSC::Wasm::TierUpCount::optimizeAfterWarmUp):

Canonical link: https://commits.webkit.org/285408@main



To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications


More information about the webkit-changes mailing list