[webkit-changes] [WebKit/WebKit] 59ca35: Replaced the DECLARE_VIRTUAL_REFCOUNTED macro with...

geoffreygaren noreply at github.com
Mon Oct 14 13:47:57 PDT 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 59ca354ec983a0f06f75fb8bdb0983d88eb1c785
      https://github.com/WebKit/WebKit/commit/59ca354ec983a0f06f75fb8bdb0983d88eb1c785
  Author: Geoffrey Garen <ggaren at apple.com>
  Date:   2024-10-14 (Mon, 14 Oct 2024)

  Changed paths:
    M Source/WTF/WTF.xcodeproj/project.pbxproj
    A Source/WTF/wtf/AbstractRefCounted.h
    A Source/WTF/wtf/AbstractRefCountedAndCanMakeWeakPtr.h
    M Source/WTF/wtf/CMakeLists.txt
    M Source/WTF/wtf/FunctionDispatcher.h
    M Source/WTF/wtf/RefCounted.h
    M Source/WebCore/Modules/WebGPU/InternalAPI/WebGPU.h
    M Source/WebCore/Modules/push-api/PushSubscriptionOwner.h
    M Source/WebCore/Modules/streams/ReadableStreamSource.h
    M Source/WebCore/Modules/webtransport/WebTransportSession.h
    M Source/WebCore/css/CSSFontFace.h
    M Source/WebCore/css/CSSRuleList.h
    M Source/WebCore/css/CSSStyleDeclaration.h
    M Source/WebCore/dom/ActiveDOMObject.h
    M Source/WebCore/loader/ContentFilterClient.h
    M Source/WebCore/page/SpeechSynthesisClient.h
    M Source/WebCore/platform/DateTimeChooser.h
    M Source/WebCore/platform/RemoteCommandListener.h
    M Source/WebCore/platform/audio/AudioDestination.h
    M Source/WebCore/platform/audio/AudioHardwareListener.h
    M Source/WebCore/platform/graphics/MediaPlayerPrivate.h
    M Source/WebCore/platform/graphics/avfoundation/SampleBufferDisplayLayer.h
    M Source/WebCore/platform/mediastream/RealtimeMediaSource.h
    M Source/WebCore/platform/mediastream/cocoa/DisplayCaptureSourceCocoa.h
    M Source/WebCore/platform/network/curl/CurlRequestClient.h
    M Source/WebCore/workers/service/background-fetch/BackgroundFetchRecordLoader.h
    M Source/WebCore/workers/service/context/SWContextManager.h
    M Source/WebKit/NetworkProcess/Downloads/DownloadManager.h
    M Source/WebKit/NetworkProcess/NetworkDataTask.h
    M Source/WebKit/UIProcess/Cocoa/ExtensionCapabilityGranter.h
    M Source/WebKit/UIProcess/FrameLoadState.h
    M Source/WebKit/UIProcess/PageLoadState.h
    M Source/WebKit/UIProcess/ResponsivenessTimer.h
    M Source/WebKit/UIProcess/WebAuthentication/Authenticator.h
    M Source/WebKit/WebProcess/GPU/GPUProcessConnection.h
    M Source/WebKit/WebProcess/Model/ModelProcessConnection.h
    M Source/WebKit/WebProcess/Network/webrtc/WebRTCMonitor.h
    M Source/WebKit/webpushd/PushService.mm

  Log Message:
  -----------
  Replaced the DECLARE_VIRTUAL_REFCOUNTED macro with an abstract base class
https://bugs.webkit.org/show_bug.cgi?id=281428
rdar://137875169

Reviewed by Chris Dumez.

Chris pointed out that macros are hard to read/understand, and can interfere
with debugging.

We can use an abstract base class instead.

I like having a class for this because it matches how we declare concrete
refcounting.

* Source/WTF/WTF.xcodeproj/project.pbxproj:
* Source/WTF/wtf/CMakeLists.txt:
* Source/WTF/wtf/FunctionDispatcher.h:
* Source/WTF/wtf/RefCounted.h:
* Source/WebCore/Modules/WebGPU/InternalAPI/WebGPU.h:
* Source/WebCore/Modules/push-api/PushSubscriptionOwner.h:
* Source/WebCore/Modules/streams/ReadableStreamSource.h:
* Source/WebCore/Modules/webtransport/WebTransportSession.h:
* Source/WebCore/css/CSSFontFace.h:
* Source/WebCore/css/CSSRuleList.h:
* Source/WebCore/css/CSSStyleDeclaration.h:
* Source/WebCore/dom/ActiveDOMObject.h:
* Source/WebCore/loader/ContentFilterClient.h:
* Source/WebCore/page/SpeechSynthesisClient.h:
* Source/WebCore/platform/DateTimeChooser.h:
* Source/WebCore/platform/RemoteCommandListener.h:
* Source/WebCore/platform/audio/AudioDestination.h:
* Source/WebCore/platform/audio/AudioHardwareListener.h:
* Source/WebCore/platform/graphics/MediaPlayerPrivate.h:
* Source/WebCore/platform/graphics/avfoundation/SampleBufferDisplayLayer.h:
* Source/WebCore/platform/mediastream/RealtimeMediaSource.h:
* Source/WebCore/platform/mediastream/cocoa/DisplayCaptureSourceCocoa.h:
(WebCore::CapturerObserver::capturerConfigurationChanged):
* Source/WebCore/platform/network/curl/CurlRequestClient.h:
* Source/WebCore/workers/service/background-fetch/BackgroundFetchRecordLoader.h:
* Source/WebCore/workers/service/context/SWContextManager.h:
* Source/WebKit/NetworkProcess/Downloads/DownloadManager.h:
* Source/WebKit/NetworkProcess/NetworkDataTask.h:
* Source/WebKit/UIProcess/Cocoa/ExtensionCapabilityGranter.h:
* Source/WebKit/UIProcess/FrameLoadState.h:
* Source/WebKit/UIProcess/PageLoadState.h:
* Source/WebKit/UIProcess/ResponsivenessTimer.h:
* Source/WebKit/UIProcess/WebAuthentication/Authenticator.h:
* Source/WebKit/WebProcess/GPU/GPUProcessConnection.h:
* Source/WebKit/WebProcess/Model/ModelProcessConnection.h:
* Source/WebKit/WebProcess/Network/webrtc/WebRTCMonitor.h:
* Source/WebKit/webpushd/PushService.mm:

Canonical link: https://commits.webkit.org/285138@main



To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications


More information about the webkit-changes mailing list