[webkit-changes] [WebKit/WebKit] 7bf250: Fix PlayStation build following 278442 at main

Ross Kirsling noreply at github.com
Tue May 7 22:05:04 PDT 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 7bf250e4832adfb28c2bf2bc518ad59958f2ae1b
      https://github.com/WebKit/WebKit/commit/7bf250e4832adfb28c2bf2bc518ad59958f2ae1b
  Author: Ross Kirsling <ross.kirsling at sony.com>
  Date:   2024-05-07 (Tue, 07 May 2024)

  Changed paths:
    M Source/WTF/wtf/FileSystem.cpp
    M Source/WTF/wtf/PlatformHave.h
    M Source/WTF/wtf/text/StringCommon.h

  Log Message:
  -----------
  Fix PlayStation build following 278442 at main
https://bugs.webkit.org/show_bug.cgi?id=273860

Reviewed by Chris Dumez.

PS needs to implement std::u8string, which itself would be trivial,
but the complex part is that the return type of std::filesystem::u8string changed from std::string to std::u8string.
We already have accommodation for this in WebKit, so let's just extend it a little further for now.

* Source/WTF/wtf/FileSystem.cpp:
(WTF::FileSystemImpl::toStdFileSystemPath):
(WTF::FileSystemImpl::fromStdFileSystemPath): Use span8 when HAVE(MISSING_U8STRING).
* Source/WTF/wtf/PlatformHave.h:
Rename HAVE(MISSING_STD_FILESYSTEM_PATH_CONSTRUCTOR) to HAVE(MISSING_U8STRING), which is what it actually means anyway.

* Source/WTF/wtf/text/StringCommon.h:
Guard overload with !HAVE(MISSING_U8STRING).

Canonical link: https://commits.webkit.org/278490@main



To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications


More information about the webkit-changes mailing list