[webkit-changes] [WebKit/WebKit] 17e093: AX: The selected children property of a list that ...
AndresGonzalezApple
noreply at github.com
Thu Mar 28 08:51:14 PDT 2024
Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 17e09328dff3bd92840e1935bf8d9962929af11c
https://github.com/WebKit/WebKit/commit/17e09328dff3bd92840e1935bf8d9962929af11c
Author: Andres Gonzalez <andresg_22 at apple.com>
Date: 2024-03-28 (Thu, 28 Mar 2024)
Changed paths:
M LayoutTests/accessibility-isolated-tree/TestExpectations
M LayoutTests/accessibility/aria-combobox-no-owns-expected.txt
M LayoutTests/accessibility/aria-combobox-no-owns.html
M LayoutTests/platform/glib/accessibility/aria-combobox-no-owns-expected.txt
M Source/WebCore/accessibility/AXCoreObject.h
M Source/WebCore/accessibility/AXObjectCache.cpp
Log Message:
-----------
AX: The selected children property of a list that is not owned or controlled by its combobox is not updated in ITM.
https://bugs.webkit.org/show_bug.cgi?id=271783
<rdar://problem/125504735>
Reviewed by Tyler Wilcock.
Covered by accessibility/aria-combobox-no-owns.html, that now passes in ITM.
When the combobox does not own or control its list, we were updating the combobox object but not the list. We now check for this scenario and update the list's selected children as appropriate.
* LayoutTests/accessibility-isolated-tree/TestExpectations:
* LayoutTests/accessibility/aria-combobox-no-owns-expected.txt:
* LayoutTests/accessibility/aria-combobox-no-owns.html:
Modernized the code of this test.
* Source/WebCore/accessibility/AXCoreObject.h:
(WebCore::Accessibility::findRelatedObjectInAncestry):
Renamed variable in the for loop for readability, to avoid confusion with the parameter that had the same name.
* Source/WebCore/accessibility/AXObjectCache.cpp:
(WebCore::AXObjectCache::handleActiveDescendantChange):
Canonical link: https://commits.webkit.org/276779@main
To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications
More information about the webkit-changes
mailing list