[webkit-changes] [WebKit/WebKit] 26bbf5: Fix PlayStation build following 276524 at main
Ross Kirsling
noreply at github.com
Sat Mar 23 06:32:56 PDT 2024
Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 26bbf5941f3e293e33cb56a93fcc7116320240a0
https://github.com/WebKit/WebKit/commit/26bbf5941f3e293e33cb56a93fcc7116320240a0
Author: Ross Kirsling <rkirsling at gmail.com>
Date: 2024-03-23 (Sat, 23 Mar 2024)
Changed paths:
M Source/JavaScriptCore/jit/ExecutableAllocator.cpp
M Source/WTF/wtf/ByteOrder.h
Log Message:
-----------
Fix PlayStation build following 276524 at main
https://bugs.webkit.org/show_bug.cgi?id=271518
Unreviewed build fix.
The names bswap16, bswap32, and bswap64 are unfortunately #defines on FreeBSD.
https://cgit.freebsd.org/src/tree/sys/sys/endian.h#n62
Per Yusuke's suggestion, rename these to `byteSwap` instead (and update `wswap` to `wordSwap` for consistency).
* Source/JavaScriptCore/jit/ExecutableAllocator.cpp:
(JSC::initializeJITPageReservation):
* Source/WTF/wtf/ByteOrder.h:
(WTF::wordSwap32): Renamed from wswap32.
(WTF::byteSwap64): Renamed from bswap64.
(WTF::byteSwap32): Renamed from bswap32.
(WTF::byteSwap16): Renamed from bswap16.
Canonical link: https://commits.webkit.org/276588@main
To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications
More information about the webkit-changes
mailing list