[webkit-changes] [WebKit/WebKit] 0edd05: Refactor isGeneric as enum and rename it to isGene...

Vitor Roriz noreply at github.com
Wed Jul 3 20:02:09 PDT 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 0edd05d59f19a69d21f7c4cff455025e9f33f8ff
      https://github.com/WebKit/WebKit/commit/0edd05d59f19a69d21f7c4cff455025e9f33f8ff
  Author: Vitor Roriz <vitor.roriz at apple.com>
  Date:   2024-07-03 (Wed, 03 Jul 2024)

  Changed paths:
    M Source/WebCore/css/CSSFontFace.h
    M Source/WebCore/css/CSSFontSelector.cpp
    M Source/WebCore/platform/graphics/FontCascadeFonts.cpp
    M Source/WebCore/platform/graphics/FontRanges.cpp
    M Source/WebCore/platform/graphics/FontRanges.h
    M Source/WebCore/platform/graphics/coretext/FontCascadeCoreText.cpp
    M Source/WebCore/platform/graphics/skia/FontCascadeSkia.cpp

  Log Message:
  -----------
  Refactor isGeneric as enum and rename it to isGenericFontFamily
https://bugs.webkit.org/show_bug.cgi?id=276199
rdar://131078219

Reviewed by Matthieu Dubet.

We are avoiding passing the information about if
"is it a generic font family" as a bool as it gets
harder to read and it carries less meaning in
comparison to a descriptive enum with appropriate values.

We are also renaming "isGeneric" to "isGenericFontFamily"
for a better description.

* Source/WebCore/css/CSSFontFace.h:
* Source/WebCore/css/CSSFontSelector.cpp:
(WebCore::CSSFontSelector::fontRangesForFamily):
* Source/WebCore/platform/graphics/FontCascadeFonts.cpp:
(WebCore::realizeNextFallback):
* Source/WebCore/platform/graphics/FontRanges.cpp:
(WebCore::FontRanges::FontRanges):
(WebCore::FontRanges::glyphDataForCharacter const):
* Source/WebCore/platform/graphics/FontRanges.h:
(WebCore::FontRanges::isGenericFontFamily const):
(WebCore::FontRanges::isGeneric const): Deleted.
* Source/WebCore/platform/graphics/coretext/FontCascadeCoreText.cpp:
(WebCore::FontCascade::fontForCombiningCharacterSequence const):
* Source/WebCore/platform/graphics/skia/FontCascadeSkia.cpp:
(WebCore::FontCascade::fontForCombiningCharacterSequence const):

Canonical link: https://commits.webkit.org/280652@main



To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications


More information about the webkit-changes mailing list